Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Deploy
Releases
Model registry
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
CyberLeo
Adélie Package Tree
Commits
c42df869
Verified
Commit
c42df869
authored
4 years ago
by
Max Rees
Browse files
Options
Downloads
Patches
Plain Diff
user/spice-gtk: disable USB redirection for now
parent
36b28239
No related branches found
Branches containing commit
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/spice-gtk/APKBUILD
+13
-5
13 additions, 5 deletions
user/spice-gtk/APKBUILD
user/spice-gtk/macro.patch
+33
-0
33 additions, 0 deletions
user/spice-gtk/macro.patch
with
46 additions
and
5 deletions
user/spice-gtk/APKBUILD
+
13
−
5
View file @
c42df869
...
...
@@ -13,19 +13,25 @@ depends="gst-plugins-good"
depends_dev
=
"gobject-introspection-dev gtk+3.0-dev"
makedepends
=
"
$depends_dev
acl-dev bash cyrus-sasl-dev eudev-dev
gst-plugins-base-dev gstreamer-dev gstreamer-tools gtk-doc
json-glib-dev libjpeg-turbo-dev libucontext-dev
libusb-dev
json-glib-dev libjpeg-turbo-dev libucontext-dev
libxrandr-dev lz4-dev meson openssl-dev opus-dev polkit-dev
py3-pyparsing py3-six spice-protocol
usbredir-dev
usbutils
zlib-dev"
py3-pyparsing py3-six spice-protocol
zlib-dev"
subpackages
=
"
$pkgname
-dev
$pkgname
-doc
$pkgname
-lang spicy
spice-glib:glib"
source
=
"https://www.spice-space.org/download/gtk/
$pkgname
-
$pkgver
.tar.xz"
source
=
"https://www.spice-space.org/download/gtk/
$pkgname
-
$pkgver
.tar.xz
macro.patch
"
build
()
{
export
CFLAGS
=
"
$CFLAGS
-lucontext"
# Note: pulseaudio support is disabled because it's deprecated.
# Audio is still supported through gstreamer.
#
# USB redirection is disabled until there is reasonable belief
# that it is endian safe.
# https://gitlab.freedesktop.org/spice/spice-gtk/-/issues/120
meson
\
--prefix
=
/usr
\
--sysconfdir
=
/etc
\
...
...
@@ -34,6 +40,7 @@ build() {
--buildtype
=
release
\
-Dcelt051
=
disabled
\
-Dpulse
=
disabled
\
-Dusbredir
=
disabled
\
.
output
ninja
-C
output
}
...
...
@@ -62,4 +69,5 @@ glib() {
"
$subpkgdir
"
/usr/lib/girepository-1.0/
}
sha512sums
=
"27b44ac9f0cee2737ce03bb3f47c62fc0ee2402c291c49fc56cffc4ccb63e2cab001a68ba865a6375d82cb38444408d59c68469783ee4279fa818d8682e902f3 spice-gtk-0.38.tar.xz"
sha512sums
=
"27b44ac9f0cee2737ce03bb3f47c62fc0ee2402c291c49fc56cffc4ccb63e2cab001a68ba865a6375d82cb38444408d59c68469783ee4279fa818d8682e902f3 spice-gtk-0.38.tar.xz
9bae6a1866c977d6b7e032e0fe1f8ce07ccfd8777e982453629d9dce284a6f02c68ab8b073865e3c36340e22dd2f83fbda4cabd3a5bc8a274b3a0bbf9c031ccd macro.patch"
This diff is collapsed.
Click to expand it.
user/spice-gtk/macro.patch
0 → 100644
+
33
−
0
View file @
c42df869
From 7363d1a0a640b6992d5967621e37c3376958d708 Mon Sep 17 00:00:00 2001
From: Frediano Ziglio <fziglio@redhat.com>
Date: Thu, 19 Mar 2020 15:50:45 +0000
Subject: [PATCH] channel-main: Avoid macro side effects
In big endian system GUINT32_TO_LE macro uses the parameter
multiple time causing serial to be incremented multiple times
instead of one.
Avoid side effects using a temporary variable.
Signed-off-by: Frediano Ziglio <fziglio@redhat.com>
Acked-by: Victor Toso <victortoso@redhat.com>
---
src/channel-main.c | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/src/channel-main.c b/src/channel-main.c
index 0a0b9ca..d7669e8 100644
--- a/src/channel-main.c
+++ b/src/channel-main.c
@@ -1384,7 +1384,8 @@
static void agent_clipboard_grab(SpiceMainChannel *channel, guint selection,
}
if (test_agent_cap(channel, VD_AGENT_CAP_CLIPBOARD_GRAB_SERIAL)) {
- *(uint32_t *)grab = GUINT32_TO_LE(c->clipboard_serial[selection]++);
+ uint32_t serial = c->clipboard_serial[selection]++;
+ *(uint32_t *)grab = GUINT32_TO_LE(serial);
grab = (void *)grab + sizeof(uint32_t);
}
--
2.24.1
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment