Skip to content
GitLab
Explore
Sign in
Register
Primary navigation
Search or go to…
Project
Adélie Package Tree
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Deploy
Releases
Model registry
Monitor
Incidents
Analyze
Value stream analytics
Contributor analytics
Repository analytics
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Keyboard shortcuts
?
Snippets
Groups
Projects
Show more breadcrumbs
CyberLeo
Adélie Package Tree
Commits
02ba4cae
Verified
Commit
02ba4cae
authored
6 years ago
by
Anna Wilcox
Browse files
Options
Downloads
Patches
Plain Diff
user/qemu: more debug, add -gtk for ppc{,64}
parent
9aba1411
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
user/qemu/APKBUILD
+5
-2
5 additions, 2 deletions
user/qemu/APKBUILD
user/qemu/debug.patch
+136
-0
136 additions, 0 deletions
user/qemu/debug.patch
with
141 additions
and
2 deletions
user/qemu/APKBUILD
+
5
−
2
View file @
02ba4cae
...
...
@@ -50,7 +50,6 @@ install="$pkgname.pre-install $pkgname.post-install"
# suid needed for qemu-bridge-helper
# strip fails on .img files
# some tests does not run on our builders
# ROMs confuse dbg
options
=
"suid !strip !check"
subpackages
=
"
$pkgname
-doc
$pkgname
-lang
$pkgname
-guest-agent:guest
$pkgname
-user
$pkgname
-system"
...
...
@@ -127,6 +126,8 @@ done
case
"
$CARCH
"
in
x86
)
_arch
=
i386
;;
x86_64
)
_arch
=
x86_64
;;
ppc64
)
_arch
=
ppc64
;;
ppc
)
_arch
=
ppc
;;
*
)
_arch
=
""
;;
esac
if
[
-n
"
$_arch
"
]
;
then
...
...
@@ -203,7 +204,8 @@ _compile_common() {
--sysconfdir
=
/etc
\
--libexecdir
=
/usr/lib/qemu
\
--disable-glusterfs
\
--disable-debug-info
\
--enable-debug-info
\
--disable-strip
\
--disable-bsd-user
\
--disable-werror
\
--disable-sdl
\
...
...
@@ -217,6 +219,7 @@ _compile_common() {
_compile_system
()
{
_compile_common
\
--audio-drv-list
=
oss,alsa
\
--enable-debug-tcg
\
--enable-kvm
\
--enable-vde
\
--enable-virtfs
\
...
...
This diff is collapsed.
Click to expand it.
user/qemu/debug.patch
0 → 100644
+
136
−
0
View file @
02ba4cae
diff --git a/user/qemu/APKBUILD b/user/qemu/APKBUILD
index 3e0be56..27ed920 100644
--- a/user/qemu/APKBUILD
+++ b/user/qemu/APKBUILD
@@ -5,7 +5,7 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=qemu
pkgver=2.12.1
-pkgrel=0
+pkgrel=95
pkgdesc="Machine emulator and virtualisation software"
url="https://www.qemu.org/"
arch="all"
@@ -56,68 +56,10 @@
subpackages="$pkgname-doc $pkgname-lang $pkgname-guest-agent:guest
$pkgname-user $pkgname-system"
_user_subsystems="
- aarch64
- alpha
- arm
- armeb
- cris
- hppa
i386
- m68k
- microblaze
- microblazeel
- mips
- mips64
- mips64el
- mipsel
- mipsn32
- mipsn32el
- or1k
- ppc
- ppc64
- ppc64abi32
- ppc64le
- s390x
- sh4
- sh4eb
- sparc
- sparc32plus
- sparc64
- tilegx
x86_64"
_system_subsystems="
- system-aarch64
- system-alpha
- system-arm
- system-cris
- system-hppa
system-i386
- system-lm32
- system-m68k
- system-microblaze
- system-microblazeel
- system-mips
- system-mips64
- system-mips64el
- system-mipsel
- system-moxie
- system-nios2
- system-or1k
- system-ppc
- system-ppc64
- system-ppcemb
- system-riscv32
- system-riscv64
- system-s390x
- system-sh4
- system-sh4eb
- system-sparc
- system-sparc64
- system-tricore
- system-unicore32
- system-x86_64
- system-xtensa
- system-xtensaeb
"
_subsystems="$_user_subsystems $_system_subsystems"
for _sub in $_subsystems; do
@@ -152,6 +94,7 @@
source="https://download.qemu.org/$pkgname-$pkgver.tar.xz
ppc32-musl-support.patch
sysinfo-header.patch
fix-lm32-underlinking.patch
+ debug.patch
$pkgname-guest-agent.confd
$pkgname-guest-agent.initd
@@ -203,7 +146,8 @@
_compile_common() {
--sysconfdir=/etc \
--libexecdir=/usr/lib/qemu \
--disable-glusterfs \
- --disable-debug-info \
+ --enable-debug-info \
+ --disable-strip \
--disable-bsd-user \
--disable-werror \
--disable-sdl \
@@ -217,6 +161,7 @@
_compile_common() {
_compile_system() {
_compile_common \
--audio-drv-list=oss,alsa \
+ --enable-debug-tcg \
--enable-kvm \
--enable-vde \
--enable-virtfs \
@@ -247,7 +192,8 @@
build() {
_compile_common \
--enable-linux-user \
--disable-system \
- --static
+ --static \
+ --target-list="i386-linux-user,x86_64-linux-user"
cd "$builddir"/build
_compile_system \
@@ -256,7 +202,8 @@
build() {
--enable-vnc-jpeg \
--enable-spice \
--enable-guest-agent \
- --disable-gtk
+ --disable-gtk \
+ --target-list="i386-softmmu"
if [ -n "$_arch" ]; then
cd "$builddir"/build-gtk
@@ -403,6 +350,7 @@
a4cbb020d6a839b5a129964027169babff2c1455170c5fec855232d999481eea2cae186fa66ceaa5
fb0130fa4e8771b23ae337ea3e5e29fd5f7dcfe7f9f7a68968f5b059bb4dd1336b0d04c118840d55885bc784a96a99b28aeacbc6a5549b2e6750c9d3099a897c ppc32-musl-support.patch
698f6b134f4ca87f4de62caf7a656841a40a451b8686ca95928f67a296e58a7493d432d9baa5f6360917865aa4929600baf1699993b0600923a066ca9d45d1da sysinfo-header.patch
2828cc612539aa93b5789de7de6d4f85d3cf82311484c0fe91fdd3efeb972057e2baa2a3809ed633d6caa1785642d49196cb282b095d7553c510c47ce7d6a702 fix-lm32-underlinking.patch
+cfa0bc3c10d64060bf2ad46fc056060527a9ab68ab36ed012eab85db8a6053a2aa81199c6850c097f56ff3d4ea8fb23ee66aec62c33117ccf7518d64105b7e30 debug.patch
d90c034cae3f9097466854ed1a9f32ab4b02089fcdf7320e8f4da13b2b1ff65067233f48809911485e4431d7ec1a22448b934121bc9522a2dc489009e87e2b1f qemu-guest-agent.confd
1cd24c2444c5935a763c501af2b0da31635aad9cf62e55416d6477fcec153cddbe7de205d99616def11b085e0dd366ba22463d2270f831d884edbc307c7864a6 qemu-guest-agent.initd
9b7a89b20fcf737832cb7b4d5dc7d8301dd88169cbe5339eda69fbb51c2e537d8cb9ec7cf37600899e734209e63410d50d0821bce97e401421db39c294d97be2 80-kvm.rules
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment