Verified Commit 8d2e00db authored by Max Rees's avatar Max Rees
Browse files

user/xf86-video-*: ensure depends= on mesa-dri and not old subpackages

If depending on the old subpackages of mesa-dri, apk is not smart enough
to determine that it should replace those old subpackages with the new
unified mesa-dri package, so we change the depends= in each reverse
dependency of those old subpackage names to force apk to purge the old
packages. As usual provides=/replaces= are a mystical art.
parent f640f3f0
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=xf86-video-ati
pkgver=19.1.0
pkgrel=1
pkgrel=2
pkgdesc="ATI video driver for X11"
url="https://www.X.Org/"
arch="all"
options="!check" # No test suite.
license="MIT"
depends="mesa-dri-ati"
depends="mesa-dri"
makedepends="eudev-dev libdrm-dev libxi-dev mesa-dev pixman-dev util-macros
xorg-server-dev"
subpackages="$pkgname-doc"
......
......@@ -9,7 +9,7 @@ url="https://xorg.freedesktop.org"
arch="pmmx x86_64"
options="!check" # No test suite.
license="MIT"
depends="mesa-dri-intel"
depends="mesa-dri"
makedepends="xorg-server-dev libxi-dev libdrm-dev mesa-dev libxvmc-dev
xcb-util-dev eudev-dev util-macros autoconf automake libtool xorgproto
libxv-dev
......
......@@ -2,12 +2,12 @@
# Maintainer: A. Wilcox <awilfox@adelielinux.org>
pkgname=xf86-video-nouveau
pkgver=1.0.16
pkgrel=0
pkgrel=1
pkgdesc="Libre Nvidia video driver for X11"
url="https://nouveau.freedesktop.org/"
arch="all"
license="MIT"
depends="mesa-dri-nouveau"
depends="mesa-dri"
makedepends="eudev-dev libdrm-dev util-macros xorgproto-dev xorg-server-dev"
subpackages="$pkgname-doc"
source="https://www.X.Org/archive/individual/driver/$pkgname-$pkgver.tar.bz2"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment