From 72c9319eb995d37e13b3ab1384850be49f4e5782 Mon Sep 17 00:00:00 2001
From: Max Rees <maxcrees@me.com>
Date: Thu, 3 Oct 2019 22:38:18 -0500
Subject: [PATCH] user/py3-zipp: bump to 0.6.0

---
 user/py3-zipp/APKBUILD  | 8 ++++----
 user/py3-zipp/scm.patch | 4 ++--
 2 files changed, 6 insertions(+), 6 deletions(-)

diff --git a/user/py3-zipp/APKBUILD b/user/py3-zipp/APKBUILD
index ba2673027c..aa57d3dc3f 100644
--- a/user/py3-zipp/APKBUILD
+++ b/user/py3-zipp/APKBUILD
@@ -5,14 +5,14 @@ pkgname=py3-zipp
 _pkgname=zipp
 _p="${_pkgname#?}"
 _p="${_pkgname%"$_p"}"
-pkgver=0.5.2
+pkgver=0.6.0
 pkgrel=0
 pkgdesc="Backport of Python 3.7's zip.Path"
 url="https://pypi.python.org/pypi/zipp"
 arch="noarch"
 # Certified net clean
 license="MIT"
-depends="python3"
+depends="python3 py3-more-itertools"
 makedepends=""
 source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/$_p/$_pkgname/$_pkgname-$pkgver.tar.gz
 	scm.patch"
@@ -30,5 +30,5 @@ package() {
 	python3 setup.py install --prefix=/usr --root="$pkgdir"
 }
 
-sha512sums="8c84b620844315ab1f1aa3c5bb29dcdf1271a0139198b5c3d6aa31ecb9a86f0dcef963819403d971ae0461c737312c064572c57ecf32d73dc973a5f69cf0375c  py3-zipp-0.5.2.tar.gz
-7e9061e3ba0e3ded95633f1baa1438f7bb7ea32cecd423001bcbafdfad93aca5bfe0a444035e41b31aeea66b31c86b22854b4f18b2cbbfda356986a2433ca677  scm.patch"
+sha512sums="18bef5aa3388ab3901bf08888127fc9cc17d8972a52f23ccf9a8035f09ee5598e17ddff833a10b81b2118461e0c517e88413518736763425a728cd0b19cc2052  py3-zipp-0.6.0.tar.gz
+6eee026c1a7a1a84c1b7584b86d4e95d1c7ba0cbed3554260196de842944a303be2f05a1c4492c95fb9592bef96906fbc643ce638a931d7d69f3e74a6647b935  scm.patch"
diff --git a/user/py3-zipp/scm.patch b/user/py3-zipp/scm.patch
index b7d0f690ee..82c6f7e550 100644
--- a/user/py3-zipp/scm.patch
+++ b/user/py3-zipp/scm.patch
@@ -1,9 +1,9 @@
 --- zipp-0.5.2/setup.cfg	2019-07-07 17:14:00.000000000 -0400
 +++ zipp-0.5.2/setup.cfg	2019-08-06 05:03:34.500180967 -0400
 @@ -22,7 +22,7 @@ packages = find:
- include_package_data = true
  python_requires = >=2.7
  install_requires = 
+ 	more_itertools
 -setup_requires = setuptools_scm >= 1.15.0
 +setup_requires = 
  
@@ -16,4 +16,4 @@
  
  if __name__ == "__main__":
 -    setuptools.setup(use_scm_version=True)
-+    setuptools.setup(version='0.5.2')
++    setuptools.setup(version='0.6.0')
-- 
GitLab